aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2020-01-27 07:21:29 +0200
committerSergey Poznyakoff <gray@gnu.org>2020-01-27 07:26:33 +0200
commitcafe11d43e7d1fb298acb0e5c78f97b8c808b4a3 (patch)
tree0e73e154bd1f24cfa8686fa4c1eb8b7c92f73dc6 /Makefile.PL
parentf3d76da04b7e918c104693b8584c4f4bd18a7c8d (diff)
downloadfile-backup-cafe11d43e7d1fb298acb0e5c78f97b8c808b4a3.tar.gz
file-backup-cafe11d43e7d1fb298acb0e5c78f97b8c808b4a3.tar.bz2
Various improvements; support for MSWin32v1.01
* Makefile.PL: Minimal Perl version 5.14.2 When building on MSWin32, require Win32API::File. * lib/File/BackupCopy.pm: Provide three different versions of the rename_backup function: for POSIX systems, for MSWin32 and a fallback for systems not falling into either category. * t/TestBackup.pm: Minor change in import.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 1947389..12e6b33 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -3,13 +3,13 @@ use warnings;
use ExtUtils::MakeMaker;
use Module::Metadata;
-WriteMakefile(
+my %makefile_args = (
NAME => 'File::BackupCopy',
VERSION_FROM => 'lib/File/BackupCopy.pm',
ABSTRACT_FROM => 'lib/File/BackupCopy.pm',
LICENSE => 'gpl_3',
AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
- MIN_PERL_VERSION => 5.006,
+ MIN_PERL_VERSION => 5.014002,
PREREQ_PM => {
'File::Temp' => 0.23
},
@@ -30,5 +30,12 @@ WriteMakefile(
}
);
-
+unless (eval { symlink("",""); 1 }) {
+ if ($^O eq 'MSWin32') {
+ $makefile_args{PREREQ_PM}{'Win32API::File'} = 0.1203;
+ }
+}
+
+WriteMakefile(%makefile_args);
+

Return to:

Send suggestions and report system problems to the System administrator.