aboutsummaryrefslogtreecommitdiff
path: root/src/ellinika/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ellinika/Makefile.am')
-rw-r--r--src/ellinika/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/ellinika/Makefile.am b/src/ellinika/Makefile.am
new file mode 100644
index 0000000..136b44f
--- /dev/null
+++ b/src/ellinika/Makefile.am
@@ -0,0 +1,43 @@
+# This file is part of Ellinika project.
+# Copyright (C) 2004,2006,2007,2008 Sergey Poznyakoff
+#
+# Ellinika is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# Ellinika is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+guiledir=$(GUILE_SITE)/$(PACKAGE)
+guile_DATA=xlat.scm cgi.scm i18n.scm config.scm dico.scm
+
+cgi.m4: Makefile
+ echo 'divert(-1)' > $@
+ echo 'changequote([,])' >> $@
+ echo 'changecom([;],[' >> $@
+ echo '])' >> $@
+ echo 'undefine([format])' >> $@
+ echo 'define([IFACE],$(APACHE_IFACE))' >> $@
+ echo 'define([GUILE_BINDIR],$(GUILE_BINDIR))' >> $@
+ echo 'define([GUILE_SITE],@GUILE_SITE@)' >> $@
+ echo 'define([PACKAGE],$(PACKAGE))'>> $@
+ echo 'define([PREFIX],$(prefix))' >> $@
+ echo 'define([SYSCONFDIR],$(sysconfdir))' >> $@
+ echo 'define([LOCALEDIR],$(datadir)/locale)' >> $@
+ echo 'define([HTMLDIR],$(HTMLDIR))' >> $@
+ echo 'divert(0)dnl' >> $@
+ echo '@AUTOGENERATED@' >> $@
+
+SUFFIXES = .scm4 .scm
+
+.scm4.scm:
+ m4 cgi.m4 $< > $@
+
+cgi.scm: cgi.scm4 cgi.m4
+config.scm: config.scm4 cgi.m4

Return to:

Send suggestions and report system problems to the System administrator.