aboutsummaryrefslogtreecommitdiff
path: root/scm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scm/Makefile.am')
-rw-r--r--scm/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/scm/Makefile.am b/scm/Makefile.am
index 481676f..73b3e84 100644
--- a/scm/Makefile.am
+++ b/scm/Makefile.am
@@ -1,5 +1,5 @@
1# This file is part of Ellinika project. 1# This file is part of Ellinika project.
2# Copyright (C) 2004, 2005, 2007 Sergey Poznyakoff 2# Copyright (C) 2004, 2005, 2007, 2015 Sergey Poznyakoff
3# 3#
4# Ellinika is free software; you can redistribute it and/or modify 4# Ellinika is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published by 5# it under the terms of the GNU General Public License as published by
@@ -20,20 +20,20 @@ CLEANFILES=dictrans.sed dictrans neatrans verbop
20EXTRA_DIST=dictrans.scm 20EXTRA_DIST=dictrans.scm
21 21
22dictrans.sed: Makefile 22dictrans.sed: Makefile
23 echo 's,=GUILE_BINDIR=,$(GUILE_BINDIR),' > $@ 23 $(AM_V_GEN){ \
24 echo 's,=GUILE_SITE=,@GUILE_SITE@,' >> $@ 24 echo 's,=GUILE_BINDIR=,$(GUILE_BINDIR),'; \
25 echo 's,\;=GUILE_COMMENT=\;,@GUILE_COMMENT@,' >> $@ 25 echo 's,=GUILE_SITE=,@GUILE_SITE@,'; \
26 echo 's,=SYSCONFDIR=,$(sysconfdir),' >> $@ 26 echo 's,\;=GUILE_COMMENT=\;,@GUILE_COMMENT@,'; \
27 echo 's,=AUTOGENERATED=,@AUTOGENERATED@,' >> $@ 27 echo 's,=SYSCONFDIR=,$(sysconfdir),'; \
28 echo 's,=AUTOGENERATED=,@AUTOGENERATED@,'; \
29 } > dictrans.sed
30
31%: %.scm
32 $(AM_V_GEN)sed -f dictrans.sed $< > $@
33 @chmod +x $@
28 34
29dictrans: $(srcdir)/dictrans.scm dictrans.sed 35dictrans: $(srcdir)/dictrans.scm dictrans.sed
30 sed -f dictrans.sed $(srcdir)/dictrans.scm > $@
31 chmod +x $@
32 36
33neatrans: $(srcdir)/neatrans.scm dictrans.sed 37neatrans: $(srcdir)/neatrans.scm dictrans.sed
34 sed -f dictrans.sed $(srcdir)/neatrans.scm > $@
35 chmod +x $@
36 38
37verbop: $(srcdir)/verbop.scm dictrans.sed 39verbop: $(srcdir)/verbop.scm dictrans.sed
38 sed -f dictrans.sed $(srcdir)/verbop.scm > $@
39 chmod +x $@

Return to:

Send suggestions and report system problems to the System administrator.