aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 28 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 302f2df..7cdcc32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,13 +14,13 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
AC_PREREQ(2.61)
-AC_REVISION(2015-01-07 14:56:15 gray)
+AC_REVISION(2015-01-10 19:52:52 gray)
AC_INIT(ellinika, 1.99.99, [gray+ellinika@gnu.org.ua])
AC_CONFIG_SRCDIR(src/cgi-bin/dict.scm4)
AC_CONFIG_AUX_DIR([build-aux])
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE([1.11 silent-rules no-exeext])
AM_CONFIG_HEADER([config.h])
@@ -104,30 +104,53 @@ AC_ARG_VAR([PROD_URL],
[URL for the production site])
AC_ARG_VAR([EXP_URL],
[URL for the experimental site])
AC_ARG_VAR([STATE],
[EXP for experimental, PROD for production])
+AC_SUBST(REAL_SCRIPT_SUFFIX)
AC_SUBST(SCRIPT_SUFFIX)
AC_SUBST(SCRIPT_DIR)
AC_SUBST(CGIDIR)
if test $APACHE_IFACE = "CGI"; then
- SCRIPT_SUFFIX=cgi
+ REAL_SCRIPT_SUFFIX=.cgi
if test -n "$TARGET_DIR"; then
SCRIPT_DIR=cgi-bin
else
SCRIPT_DIR=/cgi-bin
fi
CGIDIR='$(prefix)/cgi-bin'
else
- SCRIPT_SUFFIX=scm
+ REAL_SCRIPT_SUFFIX=.scm
SCRIPT_DIR=scm
CGIDIR='$(prefix)/scm'
-fi
-
+fi
+
+AC_ARG_WITH(script-suffix,
+ AC_HELP_STRING([--with-script-suffix=.STRING],
+ [CGI script suffix]),
+ [if test -z "$withval"; then
+ SCRIPT_SUFFIX=
+ else
+ case $withval in
+ no) SCRIPT_SUFFIX=;;
+ .*) SCRIPT_SUFFIX=$withval;;
+ *) AC_MSG_ERROR([script suffix must begin with dot])
+ esac
+ fi],
+ [SCRIPT_SUFFIX=$REAL_SCRIPT_SUFFIX])
+
+AC_ARG_WITH(script-dir,
+ AC_HELP_STRING([--with-script-dir=DIR],
+ [script directory prefix]),
+ [case $withval in
+ no) SCRIPT_DIR=;;
+ *) SCRIPT_DIR=$withval;;
+ esac])
+
AC_ARG_WITH(cgi-bin,
AC_HELP_STRING([--with-cgi-bin=DIR],
[install CGI programs in DIR [[PREFIX/cgi-bin]]]),
[CGIDIR=$withval])
dnl Check for Emacs site-lisp directory

Return to:

Send suggestions and report system problems to the System administrator.