aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 32 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 01d5b4a..be489b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,5 +21,5 @@ AC_PREREQ(2.59)
AC_REVISION($Revision$)
-AC_INIT(ellinika, 1.0, gray@gnu.org)
+AC_INIT(ellinika, 1.1, gray@gnu.org)
AC_CONFIG_SRCDIR(cgi-bin/dict.cgi.in)
-AC_CONFIG_AUX_DIR([scripts])
+AC_CONFIG_AUX_DIR([build-aux])
AC_CANONICAL_SYSTEM
@@ -63,9 +63,2 @@ AC_SUBST(GUILE_SITE)
-CGIDIR='$(prefix)/cgi-bin'
-AC_ARG_WITH(cgi-bin,
- AC_HELP_STRING([--with-cgi-bin=DIR],
- [install CGI programs in DIR [[PREFIX/cgi-bin]]]),
- [CGIDIR=$withval])
-AC_SUBST(CGIDIR)
-
HTMLDIR='$(prefix)/ellinika'
@@ -77,2 +70,30 @@ AC_SUBST(HTMLDIR)
+AC_SUBST(APACHE_IFACE,CGI)
+AC_ARG_ENABLE(cgi,
+ AC_HELP_STRING([--enable-cgi],
+ [Use CGI or SCM]),
+ [case $enableval in
+ yes) APACHE_IFACE=CGI;;
+ no) APACHE_IFACE=SCM;;
+ *) AC_MSG_ERROR([unknown argument to --enable-cgi])
+ esac])
+
+AC_SUBST(SCRIPT_SUFFIX)
+AC_SUBST(SCRIPT_DIR)
+AC_SUBST(CGIDIR)
+if test $APACHE_IFACE = "CGI"; then
+ SCRIPT_SUFFIX=cgi
+ SCRIPT_DIR=/cgi-name
+ CGIDIR='$(prefix)/cgi-bin'
+else
+ SCRIPT_SUFFIX=scm
+ SCRIPT_DIR=
+ CGIDIR='$(HTMLDIR)'
+fi
+
+AC_ARG_WITH(cgi-bin,
+ AC_HELP_STRING([--with-cgi-bin=DIR],
+ [install CGI programs in DIR [[PREFIX/cgi-bin]]]),
+ [CGIDIR=$withval])
+
AC_SUBST(BASE_HREF)
@@ -87,4 +108,4 @@ AC_SUBST(lisp_LISP)
-AC_SUBST(AUTOGENERATED)
-AUTOGENERATED=";;;; This file is generated automatically. Please do not edit."
+AC_SUBST(AUTOGENERATED,
+ ";;;; This file is generated automatically. Please do not edit. -*- buffer-read-only: t -*- vi: set ro:")

Return to:

Send suggestions and report system problems to the System administrator.