aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2004-10-08 19:53:45 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2004-10-08 19:53:45 +0000
commitb98a35c47d57415d1b67490688b13d1cf126d594 (patch)
tree51a008c47ec167a7a4eda82f403056b027fb39b7 /configure.ac
parent50e4b2a479d0a9c33e4d856e311e94985fa7e070 (diff)
downloadellinika-b98a35c47d57415d1b67490688b13d1cf126d594.tar.gz
ellinika-b98a35c47d57415d1b67490688b13d1cf126d594.tar.bz2
Reorganized
git-svn-id: file:///home/puszcza/svnroot/ellinika/trunk@202 941c8c0f-9102-463b-b60b-cd22ce0e6858
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 29 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 91525dd..147b586 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,14 +6,8 @@ AC_CONFIG_SRCDIR(cgi-bin/dict.cgi.in)
AC_CONFIG_AUX_DIR([scripts])
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE(no-exeext)
-AC_CONFIG_HEADERS([config.h])
## * Checks for programs.
-AC_PROG_CC
-AM_PROG_CC_STDC
-AC_PROG_YACC
-AM_PROG_LEX
-AC_PROG_AWK
M4='`cd $(top_srcdir); pwd`/scripts/missing --run m4'
AC_SUBST(M4)
@@ -29,6 +23,7 @@ RA_CHECK_GUILE(,
esac],
[AC_MSG_ERROR([You need Guile 1.6 or better])])
+
RA_CHECK_LIB(mysqlclient,
mysql_real_connect,
[-lm],
@@ -42,6 +37,25 @@ LIBS="$LIBS $ra_cv_lib_mysqlclient"
## Directories
## **************
+AC_SUBST(GUILE_BINDIR)
+GUILE_BINDIR=`guile-config info bindir`
+
+
+AC_SUBST(GUILE_SITE)
+GUILE_SITE=
+AC_ARG_WITH([guile-site],
+ AC_HELP_STRING([--with-guile-site],
+ [Install modules into the default guile site directory]),
+ [case $withval in
+ yes) GUILE_SITE=`guile-config info pkgdatadir`/site/'$(PACKAGE)';;
+ esac])
+
+if test "$GUILE_SITE" = ""; then
+ GUILE_SITE='$(pkgdatadir)'
+ AC_SUBST(UPDPATH)
+ UPDPATH="(set! %load-path (cons \\\"\$\$s\\\" %load-path))"
+fi
+
CGIDIR='$(prefix)/cgi-bin'
AC_ARG_WITH(cgi-bin,
AC_HELP_STRING([--with-cgi-bin=DIR],
@@ -59,9 +73,12 @@ AC_SUBST(HTMLDIR)
AC_SUBST(BASE_HREF)
AC_SUBST(TARGET_DIR)
-AC_OUTPUT(Makefile
- cgi-bin/Makefile
- data/Makefile
- src/Makefile
- xml/Makefile
- po/Makefile.in)
+AC_CONFIG_FILES(Makefile
+ cgi-bin/Makefile
+ data/Makefile
+ scm/Makefile
+ ellinika/Makefile
+ xml/Makefile
+ po/Makefile.in)
+
+AC_OUTPUT \ No newline at end of file

Return to:

Send suggestions and report system problems to the System administrator.