aboutsummaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
new file mode 100644
index 0000000..5eec565
--- /dev/null
+++ b/etc/Makefile.am
@@ -0,0 +1,60 @@
+# This file is part of Eclat
+# Copyright (C) 2012 Sergey Poznyakoff
+#
+# Eclat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# Eclat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Eclat. If not, see <http://www.gnu.org/licenses/>.
+
+noinst_PROGRAMS = flncat
+
+FLNFILES=\
+ describe-instance-status.fln\
+ describe-instances.fln\
+ describe-tags.fln\
+ start-instances.fln\
+ stop-instances.fln
+
+EXTRA_DIST=$(FLNFILES) default.fln eclat.cfin
+
+noinst_SCRIPTS=eclat.conf
+CLEANFILES=eclat.conf
+SUFFIXES=.cfin .conf
+
+if SPLIT_FORMATS
+SUFFIXES += .forlan .fln
+.fln.forlan:
+ $(AM_V_GEN)$(abs_builddir)/flncat $< default.fln > $@
+formatdir = @FORMATDIR@
+noinst_SCRIPTS += $(FLNFILES:.fln=.forlan)
+CLEANFILES += $(FLNFILES:.fln=.forlan)
+FORMATNAME = $${command}
+else
+formatdir = @FORMATDIR@
+noinst_SCRIPTS += eclat.forlan
+CLEANFILES += eclat.forlan
+eclat.forlan: $(FLNFILES) default.fln
+ $(AM_V_GEN)(cd $(srcdir); $(abs_builddir)/flncat $(FLNFILES) default.fln) > eclat.forlan
+FORMATNAME = eclat
+endif
+
+.cfin.conf:
+ $(AM_V_GEN)sed 's^FORMATDIR^$(formatdir)^;s^FORMATNAME^$(FORMATNAME)^' $< > $@
+
+install-data-local:
+ @test -z "$(DESTDIR)$(sysconfdir)" || $(mkdir_p) "$(DESTDIR)$(sysconfdir)"
+ @if [ -r $(DESTDIR)$(sysconfdir)/eclat.conf ]; then :; \
+ else ${INSTALL} -m 644 $(top_srcdir)/src/eclat.conf \
+ $(DESTDIR)$(sysconfdir)/eclat.conf; \
+ for file in $(noinst_SCRIPTS); do \
+ ${INSTALL} -m 644 $$file $(DESTDIR)$(formatdir)/$$file; \
+ done; \
+ fi

Return to:

Send suggestions and report system problems to the System administrator.