aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-10-10 19:16:16 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-10-10 19:22:57 +0300
commit800e9a67d5d2ced20192f3191b72c12707a30cd4 (patch)
tree8ded26adf647ba8e467b87110070b977500c6ca2 /tests/Makefile.am
parentaa129be43d57fac4842f0340168404a21b3927e6 (diff)
downloadeclat-800e9a67d5d2ced20192f3191b72c12707a30cd4.tar.gz
eclat-800e9a67d5d2ced20192f3191b72c12707a30cd4.tar.bz2
Improve map support.
* doc/eclat.conf.5: Document the null map. * lib/nullmap.c: New file. * lib/Makefile.am: Add new files. * lib/gdbmmap.c (gdbm_map_open): Fix gdbm_open arguments. Report a detailed error description if it fails. * lib/libeclat.h (eclat_map_drv_null): New extern. * src/eclat.c (main): Register the null map. * tests/.gitignore: Update. * tests/Makefile.am: Add new files. * tests/filemap.at: New file. * tests/gdbmload.c: New file. * tests/gdbmmap.at: New file. * tests/nullmap.at: New file. * tests/atlocal.in (GDBMLOAD): New variable. * tests/testsuite.at: Include new files.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index abe8f98..eda9ca3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -52,6 +52,8 @@ TESTSUITE_AT = \
dump01.at\
dump02.at\
exit.at\
+ filemap.at\
+ gdbmmap.at\
forlan01.at\
get-console-output.at\
hmac01.at\
@@ -60,6 +62,7 @@ TESTSUITE_AT = \
last.at\
let.at\
listall.at\
+ nullmap.at\
print01.at\
print02.at\
print03.at\
@@ -91,7 +94,12 @@ check-local: atconfig atlocal $(TESTSUITE)
#installcheck-local:
# $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
+if COND_GDBM
+ GDBMLOAD=gdbmload
+endif
+
noinst_PROGRAMS = \
+ $(GDBMLOAD)\
tforlan\
thmac\
trws\
@@ -100,6 +108,7 @@ noinst_PROGRAMS = \
LDADD = ../lib/libeclat.a ../grecs/src/libgrecs.a
INCLUDES = -I$(top_srcdir)/grecs/src/ -I$(top_srcdir)/lib
+gdbmload_LDADD=../lib/libeclat.a ../grecs/src/libgrecs.a @MAPLIBS@

Return to:

Send suggestions and report system problems to the System administrator.