aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2013-12-19 22:54:20 +0200
committerSergey Poznyakoff <gray@gnu.org.ua>2013-12-19 23:03:45 +0200
commit8d43103165e7e2f16c10d0592e5a51d86dac01ed (patch)
treec479c34f16e8a1d989fb95af462e47c318565cd8 /src/Makefile.am
parent2a69cacdfe3f43c61c65ea4359c821236b7f141c (diff)
downloadeclat-8d43103165e7e2f16c10d0592e5a51d86dac01ed.tar.gz
eclat-8d43103165e7e2f16c10d0592e5a51d86dac01ed.tar.bz2
Implement security group creation and deletion.
* doc/eclat-lssg.1: New file. * doc/eclat-sg.1: New file. * doc/Makefile.inc: Add new files. * etc/create-security-group.fln: New file. * etc/delete-security-group.fln: New file. * etc/Makefile.am: Add new files. * src/mksg-cl.opt: New file. * src/mksg.c: New file. * src/rmsg-cl.opt: New file. * src/rmsg.c: New file. * src/sg.h: New file. * src/Makefile.am: Add new files. * src/eclat.c (cmdtab): New commands "mksg" and "rmsg". * src/eclat.h (eclat_create_security_group) (eclat_delete_security_group): New protos. * src/lssg.c: Include sg.h. Use groupkw instead of the static rt[], which is removed. * src/sg-cl.opt: Use groupkw * src/sg.c (groupkw): New global. * TODO: Update.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6654f5c..9bc68d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -50,14 +50,17 @@ eclat_SOURCES=\
lszon.c\
mkimg.c\
mkinst.c\
+ mksg.c\
mksnap.c\
mktags.c\
mkvol.c\
rmaddr.c\
+ rmsg.c\
rmsnap.c\
rmvol.c\
setiattr.c\
sg.c\
+ sg.h\
startstop.c\
util.c
@@ -86,9 +89,11 @@ OPTFILES=\
lstag-cl.opt\
mkimg-cl.opt\
mkinst-cl.opt\
+ mksg-cl.opt\
mktags-cl.opt\
mkvol-cl.opt\
rmaddr-cl.opt\
+ rmsg-cl.opt\
sg-cl.opt
eclat_SOURCES += $(OPTFILES:.opt=.h)

Return to:

Send suggestions and report system problems to the System administrator.