aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-10-04 01:22:27 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-10-04 01:22:27 +0300
commit11db69e6d2b292df96845515f7df0e850b60c125 (patch)
tree9c4bb3a47ead03b6093ceed3e0142fc259a91de0 /src/Makefile.am
parent256d8b3572532af87ea5b28379cee709ad44cea6 (diff)
downloadeclat-11db69e6d2b292df96845515f7df0e850b60c125.tar.gz
eclat-11db69e6d2b292df96845515f7df0e850b60c125.tar.bz2
Implement eq/ne comparisons in forlan; Implement describe-security-groups command.
* etc/Makefile.am: Add new file. * etc/describe-security-groups.fln: New file. * lib/forlan.c: Implement equality and inequality comparisons. * lib/forlan.h (forlan_opcode_eq) (forlan_opcode_ne): New opcodes. (FORLAN_NTYPES): New constants. * lib/forlangrm.y: Add equality and inequality productions. * lib/forlanlex.l: New tokens: == and != * src/dscrsecgrps-cl.opt: New file. * src/dscrsecgrps.c: New file. * src/Makefile.am: Add new files. * src/eclat.c: Implement describe-security-groups * src/eclat.h (eclat_describe_security_groups): New proto. * src/cretags.c: Fix memory leaks. * src/deltags.c: Likewise. * src/dscrtags.c: Likewise. * tests/describe-security-groups.at: New test case. * tests/testsuite.at: Include new test case. * tests/Makefile.am: Add new test case.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index de1c17b..1f533ef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,6 +29,7 @@ eclat_SOURCES=\
dscrinstattr.c\
dscrinsts.c\
dscrinststat.c\
+ dscrsecgrps.c\
dscrvols.c\
eclat.c\
eclat.h\
@@ -50,6 +51,7 @@ OPTFILES=\
disassaddr-cl.opt\
dscraddrs-cl.opt\
dscrinststat-cl.opt\
+ dscrsecgrps-cl.opt\
generic-cl.opt
eclat_SOURCES += $(OPTFILES:.opt=.h)

Return to:

Send suggestions and report system problems to the System administrator.