aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-10-07 21:17:16 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-10-07 21:20:00 +0300
commit3f1639c2112f8242a542ca0a1b959f657d012cc9 (patch)
tree6951514621c1ac6cde192dbed7cdf736fb6bc39a /lib/Makefile.am
parent1fbcbdb432e945aa3f63be5b9170e94a0c9ef6c3 (diff)
downloadeclat-3f1639c2112f8242a542ca0a1b959f657d012cc9.tar.gz
eclat-3f1639c2112f8242a542ca0a1b959f657d012cc9.tar.bz2
Implement GDBM map backend.
* README: Document --with-gdbm * configure.ac: Detect libgdbm. New option --with-gdbm. * lib/gdbmmap.c * lib/Makefile.am (maps) [COND_GDBM]: Add new file. * lib/libeclat.h (eclat_map_drv_gdbm): New extern. * src/Makefile.am (LDADD): Add MAPLIBS. * src/eclat.c (mail) [WITH_GDBM]: Register eclat_map_drv_gdbm.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e7b9d20..829ef1b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -16,7 +16,12 @@
noinst_LIBRARIES=libeclat.a
+if COND_GDBM
+ GDBMMAP=gdbmmap.c
+endif
+
maps = \
+ $(GDBMMAP)\
filemap.c
libeclat_a_SOURCES=\

Return to:

Send suggestions and report system problems to the System administrator.