aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-09-28 11:23:09 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-09-28 11:32:04 +0300
commitac1d6cbbcf5323d5db59886b98a24c45bafa64b8 (patch)
treef2a77092e072faa680b47d9d6d960e7214e46876 /configure.ac
parentd902742081bc31a6eda274268da0178107e4abb4 (diff)
downloadeclat-ac1d6cbbcf5323d5db59886b98a24c45bafa64b8.tar.gz
eclat-ac1d6cbbcf5323d5db59886b98a24c45bafa64b8.tar.bz2
Improve testsuite. Reorganize directory structure.
* Makefile.am (SUBDIRS): Add etc (distuninstallcheck_listfiles): Ignore *.forlan files. * configure.ac: New options --split-format and --format-dir * etc/Makefile.am: New file. * etc/default.fln: New file. * etc/describe-instance-status.fln: New file. * etc/describe-instances.fln: New file. * etc/describe-tags.fln: New file. * etc/eclat.cfin: New file. * etc/flncat.c: New file. * etc/start-instances.fln: New file. * etc/stop-instances.fln: New file. * src/Makefile.am: Remove eclat.conf. It is built in /etc now. * src/eclat.conf: Remove. * src/cmdline.opt: Update. * src/config.c: New configuration statement "format-file". * src/eclat.c (format_file_option): New global. (main): Read format from format-file, if supplied. Expand keywords in its argument. * src/eclat.h (format_file_option): New extern. * tests/.gitignore: Update. * tests/Makefile.am: Add new files. * tests/describe-instance-status.at: New test case. * tests/describe-instances.at: New test case. * tests/describe-tags.at: New test case. * tests/dscrinststat.at: New test case. * tests/start-instances.at: New test case. * tests/stop-instances.at: New test case. * tests/testsuite.at (ECLAT_TEST_FORMAT): New macro. Include new test cases. * tests/trws.c: New file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8f8ccfc..7c744ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,29 @@ AC_CHECK_LIB([expat], [XML_Parse],[],
GRECS_SETUP([grecs],[tests getopt git2chg])
+#
+AC_SUBST(FORMATDIR)
+AC_ARG_ENABLE([split-format],
+ [AC_HELP_STRING([--enable-split-format],
+ [build split format files])],
+ [split_fmt=$enableval],
+ [split_fmt=no])
+
+if test $split_fmt = yes; then
+ FORMATDIR="\$(sysconfdir)/\$(PACKAGE)"
+else
+ FORMATDIR="\$(sysconfdir)"
+fi
+AM_CONDITIONAL([SPLIT_FORMATS],[test $split_fmt = yes])
+
+AC_ARG_WITH([format-dir],
+ [AC_HELP_STRING([--format-dir=DIR],
+ [install format files to that directory])],
+ [case $withval in
+ /*) FORMATDIR=$withval;;
+ *) FORMATDIR='$(prefix)/'$withval
+ esac])
+
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal])
@@ -70,7 +93,8 @@ AM_MISSING_PROG([AUTOM4TE], [autom4te])
AC_CONFIG_FILES([Makefile
lib/Makefile
- src/Makefile])
+ src/Makefile
+ etc/Makefile])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.