aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2012-09-20 11:48:40 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2012-09-20 11:48:40 +0300
commit205d53a8e930d3fd126075ab083d316cc344ebaf (patch)
tree5d6b196f3325032dd1924eff87d7d39fbe439198 /configure.ac
parent575fd3cf1af350d7ed0b661e0b8b177e3b387da7 (diff)
downloadeclat-205d53a8e930d3fd126075ab083d316cc344ebaf.tar.gz
eclat-205d53a8e930d3fd126075ab083d316cc344ebaf.tar.bz2
Require libexpat, implement DescribeTags.
* configure.ac: Require libexpat * src/descrtags.c: New file. * src/Makefile.am: Add new files. * src/accfile.c (access_file_lookup): Bugfix (stripped the first byte from the returned access_key). * src/cmdline.opt: New option --describe-tags * src/eclat.c: Register eclat_describe_tags handler. * src/eclat.h: Include expat.h (dry_run_mode): New extern. (eclat_command_describe_tags): New command code. (eclat_describe_tags): New proto. * src/startinst.c: More debugging info. Implement dry-run,
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c6384ab..fd22d37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,6 +50,12 @@ if test -z "$CURL_LIBS"; then
# FIXME: Check curl version?
fi
+# Check for libexpat
+AC_CHECK_HEADER([expat.h], [],
+ [AC_MSG_ERROR([expat.h is not found])])
+AC_CHECK_LIB([expat], [XML_Parse],[],
+ [AC_MSG_ERROR([required library libexpat is not found])])
+
# Grecs subsystem
GRECS_SETUP([grecs],[tests getopt git2chg])

Return to:

Send suggestions and report system problems to the System administrator.