aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 6973359..134a489 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -47,24 +47,25 @@ EXTRA_DIST = sample.conf GNUmakefile togit.scm
AM_MAKEINFOFLAGS = @IMPRIMATUR_MAKEINFOFLAGS@ -I$(top_srcdir)/@GRECS_SUBDIR@/doc
imprimatur_INPUT=$(info_TEXINFOS) $(cfpeek_TEXINFOS)
include ../imprimatur/imprimatur.mk
CHECK_DOCS=$(top_srcdir)/@IMPRIMATUR_MODULE_DIR@/check-docs.sh
-GENDOCS=gendocs.sh
+GENDOCS=$(srcdir)/gendocs.sh
+EXTRA_DIST += gendocs.sh
TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E
# Make sure you set TEXINPUTS.
# TEXINPUTS=/usr/share/texmf/pdftex/plain/misc/ is ok for most distributions
.PHONY: manual
manual:
TEXINPUTS=$(srcdir):$(top_srcdir)/build-aux:$(TEXINPUTS) \
MAKEINFO="$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS)" \
TEXI2DVI="$(TEXI2DVI) -t @finalout" \
- $(GENDOCS) --texi2html --html "--I=$(top_srcdir)/@GRECS_SUBDIR@/doc" $(PACKAGE) '$(PACKAGE_NAME) manual'
+ $(GENDOCS) --no-copy-images $(PACKAGE) '$(PACKAGE_NAME) manual'
# Checking
check-options:
@$(CHECK_DOCS) options \
'/OPTIONS_BEGIN/,/OPTIONS_END/s/OPTION( *\([^,][^,]*\),.*/\1/pg' \
'/@opindex *\(help\|version\|usage\),/d;s/@opindex *\([^ @,]\{2,\}\).*/\1/p' \

Return to:

Send suggestions and report system problems to the System administrator.