aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index c91b6f7..2326343 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,39 +36,16 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([stdlib.h string.h unistd.h locale.h])
# Checks for library functions.
AC_FUNC_ERROR_AT_LINE
AC_CHECK_FUNCS([memmove memset strdup strerror strtol setlocale])
-# Dirty hack: make sure HAVE_DECL_PROGRAM_INVOCATION_NAME is defined
-# This must be done before gl_ARGP, which attempts
-# an AC_CHECK_DECLS([program_invocation_name), because autoconf machinery
-# gives preference to the first definition, in spite of what the comment
-# at autoconf/status.m4:574 sais
-AC_DEFINE([HAVE_DECL_PROGRAM_INVOCATION_NAME], 1)
-
cflow_GNULIB
MU_DEBUG_MODE
-AH_TEMPLATE([PROGRAM_INVOCATION_NAME_DECLARED],
- [Is program_invocation_name declared in the system headers.])
-
-# This variable should have been set in m4/argp.m4
-if test "$ac_cv_have_decl_program_invocation_name" = no; then
- AC_LIBOBJ([pin])
- AC_DEFINE_UNQUOTED([PROGRAM_INVOCATION_NAME_DECLARED],0)
-else
- AC_DEFINE_UNQUOTED([PROGRAM_INVOCATION_NAME_DECLARED],1)
-fi
-
-
AH_BOTTOM([
-#if !PROGRAM_INVOCATION_NAME_DECLARED
-extern char *program_invocation_short_name;
-extern char *program_invocation_name;
-#endif
/* program_name is used by lib/error.c */
#define program_name program_invocation_name
#include <errno.h>
])
### Check for Emacs site-lisp directory
@@ -77,12 +54,13 @@ AM_PATH_LISPDIR
if test "$EMACS" != "no"; then
lisp_LISP='$(LISPSRC)'
fi
AC_SUBST(lisp_LISP)
# Gettext.
+AM_MKINSTALLDIRS
AM_GNU_GETTEXT([external], [need-ngettext])
AM_GNU_GETTEXT_VERSION(0.14.1)
# Doc hints.
# Select a rendition level:
# DISTRIB for stable releases (at most one dot in the version number)

Return to:

Send suggestions and report system problems to the System administrator.