aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 35 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c2a512..b491182 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# This file is part of GNU cflow
-# Copyright (C) 2005, 2007 Free Software Foundation, Inc.
+# Copyright (C) 2005, 2007, 2009 Free Software Foundation, Inc.
#
# Written by Sergey Poznyakoff
#
@@ -23,4 +23,38 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = lib src elisp po doc tests
+EXTRA_DIST = ChangeLog.2007
+
+gen_start_date = 2007-06-29
+.PHONY: make-ChangeLog
+make-ChangeLog:
+ if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --since=$(gen_start_date) | \
+ sed '/<unknown>$$/d' | fmt -s > $(distdir)/cl-t; \
+ echo " " >> $(distdir)/cl-t; \
+ echo "Local Variables:" >> $(distdir)/cl-t; \
+ echo "mode: change-log" >> $(distdir)/cl-t; \
+ echo "version-control: never" >> $(distdir)/cl-t; \
+ echo "buffer-read-only: t" >> $(distdir)/cl-t; \
+ echo "End:" >> $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+dist-hook: make-ChangeLog
+
+.PHONY: ChangeLog
+ChangeLog:
+ if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --since=$(gen_start_date) | \
+ sed '/<unknown>$$/d' | fmt -s > ChangeLog; \
+ echo " " >> ChangeLog; \
+ echo "Local Variables:" >> ChangeLog; \
+ echo "mode: change-log" >> ChangeLog; \
+ echo "version-control: never" >> ChangeLog; \
+ echo "buffer-read-only: t" >> ChangeLog; \
+ echo "End:" >> ChangeLog; \
+ fi

Return to:

Send suggestions and report system problems to the System administrator.