aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2005-03-19 11:54:08 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2005-03-19 11:54:08 +0000
commit10c08b51c954106e42a5e42c7f726834a7787fc6 (patch)
tree55b183b997c9c418a0aa660ad7adcd4c0a0c1847 /configure.ac
parente6b82b1e33b2a61353cd87b1a99b46ff05b93f5c (diff)
downloadcflow-10c08b51c954106e42a5e42c7f726834a7787fc6.tar.gz
cflow-10c08b51c954106e42a5e42c7f726834a7787fc6.tar.bz2
Added to the repository
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac65
1 files changed, 65 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..083a6e5
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,65 @@
+# This file is part of GNU cflow
+# Copyright (C) 2005 Free Software Foundation, Inc.
+#
+# Written by Sergey Poznyakoff
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+AC_PREREQ(2.59)
+AC_INIT([GNU cflow], [0.2], [gray@gnu.org])
+AC_CONFIG_SRCDIR([src/cflow.h])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE
+AC_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LEX
+
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-ll':
+#AC_CHECK_LIB([l], [main])
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_FUNC_OBSTACK
+
+# Checks for library functions.
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_FUNC_STAT
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([memmove memset strdup strerror strtol])
+
+### Check for Emacs site-lisp directory
+AM_PATH_LISPDIR
+
+if test "$EMACS" != "no"; then
+ lisp_LISP='$(LISPSRC)'
+fi
+AC_SUBST(lisp_LISP)
+
+AC_SUBST(LEXDIR)
+LEXDIR="$datadir/$PACKAGE_VERSION"
+
+AC_CONFIG_FILES([Makefile
+ doc/Makefile
+ elisp/Makefile
+ src/Makefile])
+AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.