aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am90
1 files changed, 65 insertions, 25 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ca4d108..5518bc2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,3 +4,3 @@
## This file is part of GNU Anubis.
-## Copyright (C) 2001-2014 The Anubis Team.
+## Copyright (C) 2001-2024 The Anubis Team.
##
@@ -21,3 +21,4 @@
adm_sbin_programs = anubisadm
-adm_bin_programs = anubisusr
+adm_bin_programs =
+
sbin_PROGRAMS = anubis @ANUBIS_SBIN_ADM@
@@ -26,5 +27,10 @@ EXTRA_PROGRAMS = $(adm_bin_programs) $(adm_sbin_programs)
-noinst_LIBRARIES = libanubisdb.a
-anubis_LDADD = ./libanubisdb.a $(top_builddir)/lib/libanubis.a\
- @LIBINTL@ $(GUILE_LIBS) @LIBGNUTLS_LIBS@ @GSASL_LIBS@
+noinst_LIBRARIES = libanubis.a
+anubis_LDADD = \
+ ./libanubis.a\
+ @LIBINTL@\
+ $(GUILE_LIBS)\
+ @LIBGNUTLS_LIBS@\
+ @GSASL_LIBS@\
+ $(LIBGCRYPT_LIBS)
@@ -38,5 +44,2 @@ anubis_SOURCES = \
extern.h \
- gpg.c \
- gsasl_srv.c \
- guile.c \
headers.h \
@@ -63,22 +66,34 @@ anubis_SOURCES = \
transmode.c \
- tunnel.c \
- xdatabase.c
+ tunnel.c
-anubisadm_SOURCES = anubisadm.c anubisadm.h adm.c
-anubisadm_LDADD = ./libanubisdb.a $(top_builddir)/lib/libanubis.a @LIBINTL@
-anubisusr_SOURCES = anubisusr.c anubisusr.h usr.c
-anubisusr_LDADD = ./libanubisdb.a $(top_builddir)/lib/libanubis.a @LIBINTL@ @LIBGNUTLS_LIBS@ @GSASL_LIBS@
+if GSASL_COND
+ anubis_SOURCES += gsasl_srv.c
+endif
-if TLS_COND
- TLS_C=tls.c
+if GPG_COND
+ anubis_SOURCES += gpg.c
endif
-libanubisdb_a_SOURCES = \
+if GUILE_COND
+ anubis_SOURCES += guile.c
+endif
+
+if GCRYPT_COND
+ anubis_SOURCES += idecrypt.c
+endif
+
+anubisadm_SOURCES = anubisadm.c anubisadm.h adm.c
+anubisadm_LDADD = ./libanubis.a @LIBINTL@
+anubisusr_SOURCES = anubisusr.c anubisusr.h usr.c
+anubisusr_LDADD = ./libanubis.a @LIBINTL@ @LIBGNUTLS_LIBS@ @GSASL_LIBS@
+
+libanubis_a_SOURCES = \
anubisdb.c \
dbtext.c \
- gdbm.c \
- gsasl.c \
+ getpass.c \
+ keyword.c \
+ keyword.h \
list.c \
list.h \
- md5.c \
+ mem.c \
mysql.c \
@@ -90,4 +105,21 @@ libanubisdb_a_SOURCES = \
stream.c \
- $(TLS_C) \
- url.c
+ url.c \
+ wordsplit/wordsplit.c \
+ wordsplit/wordsplit.h
+
+if TLS_COND
+ libanubis_a_SOURCES += tls.c md5sum.c xdatabase.c
+ adm_bin_programs += anubisusr
+else
+ libanubis_a_SOURCES += notls.c
+endif
+
+if GSASL_COND
+ libanubis_a_SOURCES += gsasl.c
+endif
+
+if GDBM_COND
+ libanubis_a_SOURCES += gdbm.c
+endif
+
@@ -95,3 +127,3 @@ AM_YFLAGS = -dtv
AM_LFLAGS = -dvp
-EXTRA_DIST = getopt.m4 env.opt
+EXTRA_DIST = getopt.m4 env.opt gettext.h
@@ -101,3 +133,11 @@ localedir = $(datadir)/locale
DEFS = @DEFS@ -DLOCALEDIR=\"$(localedir)\"
-AM_CPPFLAGS = @ADD_INCLUDES@ @LIBGNUTLS_INCLUDES@ -I$(top_srcdir)/lib
+AM_CPPFLAGS =\
+ @ADD_INCLUDES@\
+ @GUILE_INCLUDES@\
+ @LIBGNUTLS_INCLUDES@\
+ $(LIBGCRYPT_CFLAGS)\
+ -I$(top_srcdir)\
+ -I$(srcdir)\
+ -I$(srcdir)/wordsplit
+
SUFFIXES=.opt .c
@@ -107,3 +147,3 @@ SUFFIXES=.opt .c
-FLOWCHART_FILES=$(anubis_SOURCES) $(libanubisdb_a_SOURCES)
+FLOWCHART_FILES=$(anubis_SOURCES) $(libanubis_a_SOURCES)

Return to:

Send suggestions and report system problems to the System administrator.