aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am94
1 files changed, 16 insertions, 78 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2c89081..076734b 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,7 +2,7 @@
2## doc/Makefile.am 2## doc/Makefile.am
3## 3##
4## This file is part of GNU Anubis. 4## This file is part of GNU Anubis.
5## Copyright (C) 2001-2014 The Anubis Team. 5## Copyright (C) 2001-2024 The Anubis Team.
6## 6##
7## GNU Anubis is free software; you can redistribute it and/or modify it 7## GNU Anubis is free software; you can redistribute it and/or modify it
8## under the terms of the GNU General Public License as published by the 8## under the terms of the GNU General Public License as published by the
@@ -21,95 +21,33 @@
21man_MANS = anubis.1 21man_MANS = anubis.1
22EXTRA_DIST = $(man_MANS) pixie-dixie.pl.txt gendocs_template 22EXTRA_DIST = $(man_MANS) pixie-dixie.pl.txt gendocs_template
23 23
24RENDITION=DISTRIB
25MAKEINFOFLAGS=-D$(RENDITION)
26info_TEXINFOS = anubis.texi 24info_TEXINFOS = anubis.texi
27anubis_TEXINFOS = fdl.texi mime.texi pixie-dixie.texi rendition.texi 25anubis_TEXINFOS = fdl.texi mime.texi pixie-dixie.texi
26
27AM_MAKEINFOFLAGS=@IMPRIMATUR_MAKEINFOFLAGS@
28imprimatur_INPUT=$(info_TEXINFOS) $(anubis_TEXINFOS)
29include $(srcdir)/imprimatur/imprimatur.mk
30CHECK_DOCS=$(top_srcdir)/@IMPRIMATUR_MODULE_DIR@/check-docs.sh
31SUBDIRS = imprimatur
28 32
29clean-local: 33clean-local:
30 rm -rf manual 34 rm -rf manual
31 35
32GENDOCS=gendocs.sh 36GENDOCS=$(srcdir)/gendocs.sh
33 37
34TEXI2DVI=texi2dvi -t '@set $(RENDITION)' -E 38TEXI2DVI=texi2dvi -E
39WEBDOC_MAKEINFOFLAGS=-I $(abs_srcdir)/imprimatur
40WEBDOC_RENDITION = PUBLISH
35 41
36# Make sure you set TEXINPUTS 42# Make sure you set TEXINPUTS
37# Usual value is: 43# Usual value is:
38# /usr/share/texmf/pdftex/plain/misc:/usr/share/texmf/pdftex/config 44# /usr/share/texmf/pdftex/plain/misc:/usr/share/texmf/pdftex/config
39manual: 45manual:
40 TEXINPUTS=$(srcdir):$(top_srcdir)/build:$(TEXINPUTS) \ 46 TEXINPUTS=$(srcdir):$(top_srcdir)/build:$(TEXINPUTS) \
41 MAKEINFO="$(MAKEINFO) $(MAKEINFOFLAGS)" \ 47 MAKEINFO="$(MAKEINFO) $(WEBDOC_MAKEINFOFLAGS) -D$(WEBDOC_RENDITION) $(MAKEINFOFLAGS)" \
42 TEXI2DVI="$(TEXI2DVI) -t @finalout" \ 48 TEXI2DVI="$(TEXI2DVI) -t '@set $(WEBDOC_RENDITION)' -t @finalout" \
49 TEXI2HTML="texi2html $(WEBDOC_MAKEINFOFLAGS)" \
43 $(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual' 50 $(GENDOCS) --texi2html $(PACKAGE) '$(PACKAGE_NAME) manual'
44 51
45# Checking 52manual-rebuild: clean-local manual
46check-format:
47 @if test -n "`cat $(info_TEXINFOS) $(anubis_TEXINFOS) | tr -d -c '\t'`"; then \
48 echo "Sources contain tabs; run make untabify"; \
49 false; \
50 fi
51
52check-refs:
53 @for file in $(info_TEXINFOS) $(anubis_TEXINFOS); \
54 do \
55 sed -e = $$file | \
56 sed -n 'N;/@FIXME-.*ref/{s/\(^[0-9][0-9]*\).*@FIXME-.*ref{\([^}]*\)}.*/'$$file':\1: \2/gp}'; \
57 done > $@-t; \
58 if [ -s $@-t ]; then \
59 echo "Unresolved cross-references:"; \
60 cat $@-t;\
61 rm $@-t; \
62 else \
63 rm -f $@-t; \
64 fi
65
66check-fixmes:
67 @for file in $(info_TEXINFOS) $(anubis_TEXINFOS); \
68 do \
69 sed -e = $$file | \
70 sed -n 'N;/@FIXME{/{s/\(^[0-9][0-9]*\).*@FIXME{\([^}]*\).*/'$$file':\1: \2/gp}'; \
71 done > $@-t; \
72 if [ -s $@-t ]; then \
73 echo "Unresolved FIXMEs:"; \
74 cat $@-t; \
75 rm $@-t; \
76 false; \
77 else \
78 rm -f $@-t; \
79 fi
80
81check-writeme:
82 @grep -Hn @WRITEME $(info_TEXINFOS) $(anubis_TEXINFOS) > $@-t; \
83 if [ -s $@-t ]; then \
84 echo "Empty nodes:"; \
85 cat $@-t; \
86 rm $@-t; \
87 false;\
88 else \
89 rm $@-t; \
90 fi
91
92check-unrevised:
93 @grep -Hn @UNREVISED $(info_TEXINFOS) $(anubis_TEXINFOS) > $@-t; \
94 if [ -s $@-t ]; then \
95 echo "Unrevised nodes:"; \
96 cat $@-t; \
97 rm $@-t; \
98 false;\
99 else \
100 rm $@-t; \
101 fi
102
103all-check-docs: check-format check-refs check-fixmes check-writeme \
104 check-unrevised
105
106check-docs:
107 @$(MAKE) -k all-check-docs
108
109master-menu:
110 @emacs -batch -l mastermenu.el -f make-master-menu $(info_TEXINFOS)
111
112untabify:
113 @emacs -batch -l untabify.el $(info_TEXINFOS) $(anubis_TEXINFOS)
114 53
115final: untabify master-menu

Return to:

Send suggestions and report system problems to the System administrator.