aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWojciech Polak <polak@gnu.org>2003-05-08 21:13:41 +0000
committerWojciech Polak <polak@gnu.org>2003-05-08 21:13:41 +0000
commita8b3ac7c3f07f64e1be1c362cd70dd8291fe3b46 (patch)
treeb2bc1a6b18b25a88273b308b0343c8872dd0d0d6 /configure.ac
parentc86078066c39063eeb0947f48b2d7cac5713d3e2 (diff)
downloadanubis-a8b3ac7c3f07f64e1be1c362cd70dd8291fe3b46.tar.gz
anubis-a8b3ac7c3f07f64e1be1c362cd70dd8291fe3b46.tar.bz2
Fixed OpenSSL compilation (broken with_gnutls=no).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 33 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index c72ce4c..2a8213c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,7 +180,7 @@ AC_ARG_WITH(openssl,
[with_openssl=no])
if test "$with_openssl" = "yes"; then
- with_gnutls = no
+ with_gnutls=no
fi
if test "$with_openssl" = "yes"; then
@@ -211,34 +211,34 @@ if test "$with_openssl" = "yes"; then
fi
fi
- if test "$with_gnutls" = "yes"; then
- AC_CHECK_LIB(gcrypt, main,, with_gnutls=no)
- AC_CHECK_LIB(gnutls, main,, with_gnutls=no)
- fi
- if test "$with_gnutls" = "yes"; then
- findgnutlsdir() { :
- if test -f "$1/include/gnutls/gnutls.h"; then
- gnutlsdir=1
- INCLUDES="$INCLUDES -I$1/include"
- AC_MSG_CHECKING(for $1/include/gnutls/gnutls.h)
- AC_MSG_RESULT([yes])
- return 0
- fi
- return 1
- }
- for maindir in /usr/pkg /opt /sw; do
- findgnutlsdir $maindir && break 2
- done
- if test $gnutlsdir; then
- AC_DEFINE(HAVE_GNUTLS_GNUTLS_H, 1, [Define to 1 if HAVE_GNUTLS_GNUTLS_H is requested.])
- else
- AC_CHECK_HEADERS(gnutls/gnutls.h)
+if test "$with_gnutls" = "yes"; then
+ AC_CHECK_LIB(gcrypt, main,, with_gnutls=no)
+ AC_CHECK_LIB(gnutls, main,, with_gnutls=no)
+fi
+if test "$with_gnutls" = "yes"; then
+ findgnutlsdir() { :
+ if test -f "$1/include/gnutls/gnutls.h"; then
+ gnutlsdir=1
+ INCLUDES="$INCLUDES -I$1/include"
+ AC_MSG_CHECKING(for $1/include/gnutls/gnutls.h)
+ AC_MSG_RESULT([yes])
+ return 0
fi
- AC_LIBOBJ(tls)
- AC_DEFINE(USE_GNUTLS, 1, [Define to 1 if USE_GNUTLS is requested.])
+ return 1
+ }
+ for maindir in /usr/pkg /opt /sw; do
+ findgnutlsdir $maindir && break 2
+ done
+ if test $gnutlsdir; then
+ AC_DEFINE(HAVE_GNUTLS_GNUTLS_H, 1, [Define to 1 if HAVE_GNUTLS_GNUTLS_H is requested.])
else
- AC_MSG_RESULT([Disabling GnuTLS support...])
+ AC_CHECK_HEADERS(gnutls/gnutls.h)
fi
+ AC_LIBOBJ(tls)
+ AC_DEFINE(USE_GNUTLS, 1, [Define to 1 if USE_GNUTLS is requested.])
+else
+ AC_MSG_RESULT([Disabling GnuTLS support...])
+fi
dnl Use option --with-pcre to compile PCRE library support.
AC_ARG_WITH(pcre,
@@ -296,19 +296,19 @@ fi
AC_CONFIG_FILES([Makefile
build/Makefile
build/guile-1.6/Makefile
- m4/Makefile
- intl/Makefile
- po/Makefile.in
+ contrib/Makefile
doc/Makefile
- src/Makefile
- scripts/Makefile
examples/Makefile
- guile/Makefile
examples/pam/Makefile
+ guile/Makefile
+ intl/Makefile
+ m4/Makefile
+ po/Makefile.in
+ scripts/Makefile
+ src/Makefile
testsuite/Makefile
testsuite/data/Makefile
testsuite/etc/Makefile
- contrib/Makefile
])
AC_OUTPUT

Return to:

Send suggestions and report system problems to the System administrator.