aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2004-12-17 12:01:48 +0000
committerSergey Poznyakoff <gray@gnu.org.ua>2004-12-17 12:01:48 +0000
commita7d042a9389fc2653c564fe7b89f42086d3e3535 (patch)
tree6ba12106374a7f819408e20aea8fa34d06059d3c /configure.ac
parentbe0cf965b7957a54c04a60853bd219b6fe976606 (diff)
downloadanubis-a7d042a9389fc2653c564fe7b89f42086d3e3535.tar.gz
anubis-a7d042a9389fc2653c564fe7b89f42086d3e3535.tar.bz2
Use -Wno-deprecated gcc flag if GSASL support is enabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 24 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 77daca6..434c5b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,6 +188,25 @@ AC_SUBST(ANUBIS_DEFINES)
AC_SUBST(ANUBIS_SBIN_ADM)
AC_SUBST(ANUBIS_BIN_ADM)
+dnl Use option --enable-gcc-debug to enable GCC debug code.
+AC_ARG_ENABLE(gcc-debug,
+ AC_HELP_STRING([--enable-gcc-debug],
+ [enable GCC DEBUG code]),
+ [enable_gcc_debug=yes],
+ [enable_gcc_debug=no])
+if test "$enable_gcc_debug" = "yes" && (test "$GCC" = "yes"); then
+ if test -z "$CFLAGS_CUSTOM"; then
+ CFLAGS="-Wall -ggdb"
+ else
+ CFLAGS="$CFLAGS -ggdb"
+ fi
+ AC_MSG_RESULT([Enabling GCC DEBUG support...])
+else
+ if test -z "$CFLAGS_CUSTOM" && (test "$GCC" = "yes"); then
+ CFLAGS="-Wall -O2"
+ fi
+fi
+
dnl Use option --with-gsasl to compile GSASL library support.
MU_CHECK_GSASL(0.2.3, [
AC_DEFINE(WITH_GSASL,1,[Define if Anubis is using GNU SASL])
@@ -195,6 +214,9 @@ MU_CHECK_GSASL(0.2.3, [
ANUBIS_SBIN_ADM='$(adm_sbin_programs)'
ANUBIS_BIN_ADM='$(adm_bin_programs)'
M4_DEFS="$M4_DEFS -DWITH_GSASL"
+ if test "$GCC" = "yes"; then
+ CFLAGS="$CFLAGS -Wno-deprecated"
+ fi
AC_CHECK_LIB(gdbm, gdbm_open,
[LIBS="$LIBS -lgdbm"
@@ -301,7 +323,7 @@ if test "$with_openssl" = "yes"; then
else
AC_CHECK_HEADERS(openssl/ssl.h)
fi
- M4_DEFS="$M4_DEFS -DWITH_SSL"
+ M4_DEFS="$M4_DEFS -DWITH_SSL -DWITH_OPENSSL"
AC_DEFINE(USE_OPENSSL, 1, [Define to 1 if USE_OPENSSL is requested.])
AC_MSG_RESULT([Enabling OpenSSL support...])
fi
@@ -311,7 +333,7 @@ if test $with_gnutls = yes; then
AC_CHECK_HEADERS(gnutls/gnutls.h)
if test $ac_cv_header_gnutls_gnutls_h != no; then
AM_PATH_LIBGNUTLS("1.0.0",
- [M4_DEFS="$M4_DEFS -DWITH_SSL"
+ [M4_DEFS="$M4_DEFS -DWITH_SSL -DWITH_GNUTLS"
AC_DEFINE(USE_GNUTLS, 1,
[Define to 1 if USE_GNUTLS is requested.])],
[with_gnutls = no
@@ -386,25 +408,6 @@ fi
AC_DEFINE_UNQUOTED(DEFAULT_UNPRIVILEGED_USER, "$with_unprivileged_user",
[Define the default unprivileged user.])
-dnl Use option --enable-gcc-debug to enable GCC debug code.
-AC_ARG_ENABLE(gcc-debug,
- AC_HELP_STRING([--enable-gcc-debug],
- [enable GCC DEBUG code]),
- [enable_gcc_debug=yes],
- [enable_gcc_debug=no])
-if test "$enable_gcc_debug" = "yes" && (test "$GCC" = "yes"); then
- if test -z "$CFLAGS_CUSTOM"; then
- CFLAGS="-Wall -ggdb"
- else
- CFLAGS="$CFLAGS -ggdb"
- fi
- AC_MSG_RESULT([Enabling GCC DEBUG support...])
-else
- if test -z "$CFLAGS_CUSTOM" && (test "$GCC" = "yes"); then
- CFLAGS="-Wall -O2"
- fi
-fi
-
dnl Check for Emacs site-lisp directory
AM_PATH_LISPDIR
if test "$EMACS" != "no"; then

Return to:

Send suggestions and report system problems to the System administrator.