aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-04-19 11:02:12 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-04-19 11:02:12 +0300
commit884c5ffde12904a7ccf394eb31c5e7cf13ce554c (patch)
treea1711a6950a79f59a2c179ece9df54c3f8975872 /configure.ac
parentc5416aa2097f666cfc7701210872000871f65abb (diff)
downloadanubis-884c5ffde12904a7ccf394eb31c5e7cf13ce554c.tar.gz
anubis-884c5ffde12904a7ccf394eb31c5e7cf13ce554c.tar.bz2
Use GINT for integrating with Guile.
* gint: New module. * Makefile.am, configure.ac: Use gint. * bootstrap.conf: Initialize git submodules. * src/Makefile.am: Include gint.mk * am/guile.m4: Remove. * src/guile.c (guile_safe_exec): Use scm_c_catch instead of the deprecated scm_internal_lazy_catch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 11 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 9947012..cf6c2fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,10 +82,10 @@ AH_BOTTOM([
AC_CHECK_LIB(socket, socket)
AC_CHECK_LIB(nsl, gethostbyaddr)
-AC_SUBST(INCLUDES)
+AC_SUBST(ADD_INCLUDES)
case $build in
*-apple-darwin*)
- INCLUDES="$INCLUDES -I/usr/include" ;;
+ ADD_INCLUDES="$ADD_INCLUDES -I/usr/include" ;;
esac
dnl Internationalization macros.
@@ -103,26 +103,14 @@ case "${withval}" in
*) AC_MSG_ERROR(bad value ${withval} for --without-guile) ;;
esac],[useguile=yes])
-AC_SUBST(M4_DEFS)
-
-AC_SUBST(GUILE_INCLUDES)
-AC_SUBST(GUILE_LIBS)
-AC_SUBST(GUILE_BINDIR)
-AC_SUBST(GUILE_SNARF_VERSION)
-AC_SUBST(GUILE_SCRIPTS)
+AC_SUBST([M4_DEFS])
+AC_SUBST([GUILE_SCRIPTS])
if test x"$useguile" = x"yes"; then
- MU_CHECK_GUILE(,[
- AC_DEFINE(WITH_GUILE,1,[Enable Guile support])
- GUILE_INCLUDES=`guile-config compile`
- GUILE_LIBS=`guile-config link`
- GUILE_BINDIR=`guile-config info bindir`
- GUILE_SCRIPTS='$(GUILE_SCM)'
- M4_DEFS="$M4_DEFS -DWITH_GUILE"
- case "$GUILE_VERSION" in
- 16|17) GUILE_SNARF_VERSION="1.6";;
- *) GUILE_SNARF_VERSION="1.6";;
- esac
- ],[useguile=no])
+ GINT_INIT([gint],[1.8 nodoc std-site-dir],
+ [AC_DEFINE(WITH_GUILE,1,[Enable Guile support])
+ GUILE_SCRIPTS='$(GUILE_SCM)'
+ M4_DEFS="$M4_DEFS -DWITH_GUILE"],
+ [useguile=no])
fi
if test x"$useguile" = x"no"; then
AC_MSG_RESULT([Disabling GUILE support...])
@@ -148,7 +136,7 @@ else
findgpgmedir() { :
if test -f "$1/include/gpgme.h"; then
gpgmedir=1
- INCLUDES="$INCLUDES -I$1/include"
+ ADD_INCLUDES="$ADD_INCLUDES -I$1/include"
AC_MSG_CHECKING(for $1/include/gpgme.h)
AC_MSG_RESULT([yes])
return 0
@@ -414,6 +402,7 @@ AC_CONFIG_FILES([Makefile
build/Makefile
build/guile-1.6/Makefile
contrib/Makefile
+ gint/Makefile
doc/Makefile
elisp/Makefile
examples/Makefile

Return to:

Send suggestions and report system problems to the System administrator.