aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org.ua>2010-08-03 14:35:56 +0300
committerSergey Poznyakoff <gray@gnu.org.ua>2010-08-03 14:35:56 +0300
commit7875612f049fa2fa39e3c7bbf2d82c2908052d77 (patch)
tree5a7d8f364a160723a3881045427c94b16621d55b /configure.ac
parent7c91506f668904d2e0a26940587bad8a623e2f55 (diff)
downloadanubis-7875612f049fa2fa39e3c7bbf2d82c2908052d77.tar.gz
anubis-7875612f049fa2fa39e3c7bbf2d82c2908052d77.tar.bz2
Fix detection of GNU TLS and the corresponding code.
* am/libgnutls.m4: Remove. * am/gnutls.m4: New file. * configure.ac: Set version number 4.1.91. Remove gnutls checking, use ANUBIS_CHECK_TLS instead. (TLS_COND): New condition. * src/Makefile.am [TLS_COND] (TLS_C): New variable. (libanubisdb_a_SOURCES): Use TLS_C. (INCLUDES): Replace LIBGNUTLS_CFLAGS with LIBGNUTLS_INCLUDES. * testsuite/Makefile.am (INCLUDES): Replace LIBGNUTLS_CFLAGS with LIBGNUTLS_INCLUDES. * testsuite/etc/Makefile.am: Add missing AM_V_GENs. * src/anubisusr.c: Uniformly use USE_GNUTLS to protect tls-specific parts of code. * src/anubisusr.h: Likewise. * src/headers.h: Likewise. * src/help.c: Likewise. * src/main.c: Likewise. * src/quit.c: Likewise. * src/rcfile.c: Likewise. * testsuite/mta.c: Likewise. * src/tls.c: Likewise. (print_x509_certificate_info): Use gnutls_fingerprint instead of the deprecated gnutls_x509_fingerprint. * src/smtprepl.c (smtp_reply_read): Fix coredump. * NEWS: Update.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 6 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index a86ba98..01340e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@ dnl with GNU Anubis. If not, see <http://www.gnu.org/licenses/>.
dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNU Anubis], [4.1.90], [bug-anubis@gnu.org])
+AC_INIT([GNU Anubis], [4.1.91], [bug-anubis@gnu.org])
AC_PREREQ([2.63])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_AUX_DIR([build])
@@ -248,32 +248,10 @@ MU_CHECK_GSASL(0.2.3, [
AC_LIBOBJ(lbuf)])
-dnl Use option --without-gnutls to NOT compile GnuTLS library support.
-AC_ARG_WITH(gnutls,
- AC_HELP_STRING([--without-gnutls],
- [without GnuTLS library support]),
- [with_gnutls=${withval}],
- [with_gnutls=yes])
-
-if test $with_gnutls = yes; then
- AC_CHECK_HEADERS(gnutls/gnutls.h)
- if test $ac_cv_header_gnutls_gnutls_h != no; then
- AM_PATH_LIBGNUTLS("1.0.0",
- [M4_DEFS="$M4_DEFS -DWITH_SSL -DWITH_GNUTLS"
- AC_DEFINE(USE_GNUTLS, 1,
- [Define to 1 if USE_GNUTLS is requested.])],
- [with_gnutls = no
- AC_MSG_RESULT([Disabling GnuTLS support...])])
- if test $with_gnutls = yes; then
- # Accomodate for incompatibilities of gnults 1.0.16 (and,
- # eventually, newer versions)
- AC_CHECK_FUNC(gnutls_x509_fingerprint,:
- [AH_BOTTOM([
-#define gnutls_x509_fingerprint gnutls_fingerprint
-])])
- fi
- fi
-fi
+ANUBIS_CHECK_TLS([
+ M4_DEFS="$M4_DEFS -DWITH_SSL -DWITH_GNUTLS"
+ AC_DEFINE(USE_GNUTLS, 1, [Define to 1 if USE_GNUTLS is requested.])])
+AM_CONDITIONAL([TLS_COND], [test $anubis_cv_gnutls = yes])
dnl Use option --with-socks-proxy to compile SOCKS v4/5 proxy support.
AC_ARG_WITH(socks-proxy,
@@ -380,7 +358,7 @@ WITH_SQL=$WITH_SQL
WITH_MYSQL=$WITH_MYSQL
WITH_POSTGRES=$WITH_POSTGRES
WITH_GSASL=$WITH_GSASL
-with_gnutls=$with_gnutls
+with_gnutls=$anubis_cv_gnutls
with_socks_proxy=$with_socks_proxy
with_pcre=$with_pcre
with_pam=$with_pam

Return to:

Send suggestions and report system problems to the System administrator.