aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSergey Poznyakoff <gray@gnu.org>2019-08-26 14:13:14 +0300
committerSergey Poznyakoff <gray@gnu.org>2019-08-26 14:13:14 +0300
commitadf16c29939378f3eaa716239da53bb7e3ef6283 (patch)
tree5aabf2387a5ece4baf01a6f420a5b03b0f4eb72a /Makefile.PL
parentd9d63339f7df96d7dfcdbd11edbe996359b5813e (diff)
downloadacmeman-adf16c29939378f3eaa716239da53bb7e3ef6283.tar.gz
acmeman-adf16c29939378f3eaa716239da53bb7e3ef6283.tar.bz2
Don't distribute a copy of AutoInstall.pmv2.00
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 43555f8..0d093a8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,13 +1,12 @@
# -*- perl -*-
use strict;
-use lib 'inc';
use Module::Metadata;
use Getopt::Long qw(:config gnu_getopt no_ignore_case pass_through);
use ExtUtils::MakeMaker;
my %makefile_args = (
NAME => 'App::Acmeman',
- ABSTRACT_FROM => 'acmeman',
+ ABSTRACT => 'manages ACME certificates',
VERSION_FROM => 'lib/App/Acmeman.pm',
AUTHOR => 'Sergey Poznyakoff <gray@gnu.org>',
LICENSE => 'gpl_3',
@@ -54,9 +53,11 @@ my %makefile_args = (
my $no_autoinstall;
GetOptions('no-autoinstall|N' => \$no_autoinstall) or exit(1);
unless ($no_autoinstall) {
- require ExtUtils::AutoInstall;
- ExtUtils::AutoInstall->import(-core => $makefile_args{PREREQ_PM});
- delete $makefile_args{PREREQ_PM};
+ eval {
+ require ExtUtils::AutoInstall;
+ ExtUtils::AutoInstall->import(-core => $makefile_args{PREREQ_PM});
+ delete $makefile_args{PREREQ_PM};
+ };
}
WriteMakefile(%makefile_args);

Return to:

Send suggestions and report system problems to the System administrator.